bycj.net
当前位置:首页 >> mAtlAB找不到vs编译器 >>

mAtlAB找不到vs编译器

现在用的电脑多数是WIN64位机,但是在安装MATLAB2011a时并不能顺利安装编译器这是应为在64位机上安装MATLAB时并没有安装编译器.因此就带来不能使用m文件等一系列问题.那么就需要手动安装,但是网上的手动安装教程都是残缺

如果你想借用一个C编译器(有大量的计算要快得多),比MATLAB MATLAB命令可以参考MEX.

应该是2009版的matlab还不能识别2010版的VS.你可以尝试一下2010版的matlab

①选y后,matlab会列出当前机器上已经安装的、且与当前matlab版本兼容的所有c编译器,一般而言,matlab都会自带一个lcc编译器,然而lcc目前仅支持32位的matlab,所以你的机器上没有;②选n后,matlab会列出所有与当前matlab版本兼容

你的matlab是什么版本的,可能是版本比较早,不认识VS2008的编译器

问题描述:系统为win7 64bits,软件为matlab2009a和vs2008,在matlab中输入命令行max -setup,找不到vs2008编译器. 解决方法: 1.下载microsoft visual c++ 2008 express for matlab,按里面的readme.txt执行操作 place these three files in c:

目前我解决了,就是要装一个比较第一点版本的VS,比如你的matlab是2010版的,那么你的VS版本最好是2008年的,我就是这么解决的,如果你的VS是2010年的,那么你就装一个2011或者2012年的matlab!不知道你们可以么?

那么你按照提示去下载编译器即可如果在linux系统下是的话,是非常非常方便的windows下很麻烦

mbuild的作用是把*.c, *.cpp之类的文件编译连接成独立应用,当然需要C++编译器的支持.不同版本所支持的编译器是不一样的,详细情况需要查阅相应版本的文档.从你现在显示的信息看,你的系统里没有可用的C++编译器,如果想用,那就安装一个吧.

我告诉这个问题困扰了 我很久~~网上各种解释很难实现,正解是:你先装32位操作系统后,在非系统盘安装matlab(32位版本),然后再重装系统,装64位的,系统装好后,直接就可以运行matlab(32位版本,编译器什么都是ok的);这样你既可以享受64位系统的高速体验,又不影响matlab编译器的使用;

rjps.net | ppcq.net | yydg.net | wlbk.net | jingxinwu.net | 网站首页 | 网站地图
All rights reserved Powered by www.bycj.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com